Custom Contact Forms Magento® 2 Extension
User Manual

This is the user manual of Magento® 2 Custom Contact Forms. To see what this extension can do, go to
the Magento® 2 Custom Contact Forms product page . You can find the full release info and version
history of this extension here.
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Configuring Custom Contact Forms
To configure the extension, navigate to Content > Contact Forms > Configuration in the left Admin Panel
menu, or go to Stores > Configuration and select Plugin Company > Contact Forms from the left side
menu.
Using the extension’s config page you can modify the Custom Contact Forms general and default notification
settings as further explained below.
It’s possible to configure the extension per store view using the dropdown menu at the top left corner of the
page.
To save any changes made in the Custom Contact Forms settings, click the ‘Save Config’ button in the top
right corner of the configuration page.

General Settings
In the General Settings section you can:
Enable breadcrumbs navigation at the top of contact form pages.
Choose to create a front-end page for new contact forms by default. This can also be defined for each
form separately in the Form Settings tab, where you can enter the form’s URL key.
Optionally enter a default URL prefix and suffix for all form pages.
Enable ReCaptcha, a free Google spam protection service, by entering your personal API keys. These can
be obtained by signing up here.

Default Notification Settings
In the two bottom sections of the configuration page you can set up the default customer and admin
notification settings.

By enabling the e-mail notifications, the customer and/or admin will be notified by e-mail when a contact
form has been submitted.
You can enter the default notification recipient(s), the sender name and e-mail address, and the notification
subject.
All of these settings can also be configured for each form separately in the Customer Notification and Admin
Notification tabs.
In the Default Admin Notifications Settings, you can also choose to attach uploaded files to the admin
notification e-mail of forms that include the file upload component. Alternatively, you can display all uploaded
files as links by adding the variable {{var uploaded_file_links}} in the Admin Notification content.

Creating a Custom Contact Form
Navigate to Content > Contact Forms > Manage Forms in the left Admin Panel menu to create and
manage your custom contact forms.
Create a new form by clicking the ‘Add New Form’ button in the top right corner of the page.

Use the following tabs of the form view to create and configure your contact form:
Form Builder
Conditional Form Fields
Form Settings
Front-end Style
Custom Javascript
Customer Notification
Admin Notification
General Translations
Form Field Translations
Form Submissions
Store Views (for multi-store setup)

Form Builder
In the Form Builder interface you can build up your contact form by selecting form components on the right
side of the page and dragging and dropping them in the Contact Form area on the left.
When creating a new form, a default contact form will be shown in the Contact Form area which can be used
as a starting point. If you prefer to start from scratch, you can remove individual components by dragging
them out of the Contact Form area.
You can duplicate an existing form using the ‘Copy Form’ button at the top of the form view.

Form Components
The form components are categorized in the five tabs on the right side of the Form Builder.
The Input tab contains various text input fields, including fields with a prepended / appended text or
checkbox.

The Select tab includes fields for selecting dates, date ranges, time and files. With the upload component,
files can be selected or dragged and dropped into the upload field.

The Options tab provides various fields for selecting one or multiple options. The dropdown menu and radio
buttons can be used if only one out of several options should be chosen, while the list box and the
checkboxes allow multiple selections.

The Other tab contains a Form Page and Form Section component, a newsletter subscription checkbox, a
submit button and two different Captcha functionalities: Google ReCaptcha and Visual Captcha. Please note
that ReCaptcha will only work if it’s enabled in the extension’s General Settings.

The Text tab components can be used to add paragraphs and content headings to the contact form.

Adding and Moving Form Components
Selected form components can be added to the form and rearranged by dragging and dropping them in the
Contact Form area. A grey block will appear when the component is hovering above a suitable space to be
dropped.

Configuring Form Components
Once a form field is added to the contact form, you can configure its settings by selecting it. A pop-over will
appear on the right showing the configuration options, which vary per component. You can find a short
description of the most important form field settings below.

The form field ID / Name serves as an identifier for admin reference and can also be used as a custom
variable in the form’s customer notifications and admin notifications. To make sure all form data is
submitted correctly, it’s important to assign a unique ID to each form component, without using any
spaces. Best practice is to use short IDs that describe the content of the form component, such as name,
email, department, contact-method, etc.
The Label Text is displayed on the left side of each form component, a Placeholder can be
shown inside input fields and a Help Text can be added below input and selection fields.
You can optionally enter a Default Value for input fields, which also support automatically prefilled
variables such as customer name, contact details and product attributes. In the default form, the ‘Name’
and ‘E-mail’ fields are automatically filled in for logged in customers using the variables {{var
customer.getName()}} and {{var customer.getEmail()}}. If the specified variables are not found, the
input fields remain empty. You can read all about configuring automatically prefilled form variables here.
Most form components can be made Required, ensuring that a form cannot be submitted without
providing the required data.
The input fields include an optional Validation function which verifies if the input is entered using the
correct format (e.g. a number, e-mail address, URL, date, etc).
The option fields can be configured by entering a list of Options, Radios or Checkboxes, which can
include a default/preselected value by adding a * in front of a specific option, for example *Option One.
The input and selection components have an adjustable Input Size and Height.
All form components can be further customized using the Custom CSS field in the Front-end Style tab by
entering the Custom CSS Class(es) per form field.

Creating Form Pages
The Form Page component in the Other tab can be used for dividing your form into multiple pages or tabs,
which can be browsed through using the buttons at the bottom of each form page (see multi-page contact
form example).

Once added to the contact form, each form page can be given a custom title which is shown in a navigation
bar at the top of the contact form.
Please note that in order to modify the first form page title, you need to insert a form page component at the
top of your contact form as exemplified below.

Creating Form Sections and Columns
A form can also be divided into multiple sections or columns using the Form Section component from the
Other tab (see multi-column contact form example).
Once added to the contact form, you can select the Form Section component to configure its title, layout and
heading type in a pop-over.
Using the ‘Layout’ dropdown menu, you can choose to add a Full Width, 1 Column or 2 Columns section to the
contact form. The 2 Columns layout will evenly divide the fields within a section into two columns.

Conditional Form Fields
In the Conditional Form Fields tab you can make any of the form components that have been added to the
contact form conditional, meaning that the form component only appears on the front-end under specified
conditions.
Select the form component that should be made conditional from the dropdown menu and click the ‘Add
Field’ button. The form components are listed in the dropdown menu by their IDs which can be edited in the
Form Builder tab.

Click the ‘Add condition’ button to specify under which condition form field A should be shown, choosing the
value(s) that should / should not be selected or entered in form field B.

To configure the condition you can choose whether form field B should:
equal the specified value(s);
not equal the specified value(s);
include all of the specified value(s);
include at least one of the specified value(s);
match the specified regular expression.
In the example below, the input field ‘phone’ (A) should be shown under the condition that at least the value
‘Phone’ is selected from the ‘contact-method’ dropdown menu (B).

You can add more conditions per form field by clicking the ‘Add condition’ button, or delete a condition by
clicking the red cross icon.

Click the recycle bin icon to delete a conditional form field.

Form Settings
In the Form Settings tab you can:
Enter a form name for admin reference, which will be also shown in the breadcrumbs navigation and
contact form page title (if applicable).
Choose to create a new front-end page for the contact form. If you want to add the form to a CMS page,
block or layout update instead, you can do this by creating a custom contact form widget.
Enter a custom URL key for the form page (if applicable). The optional URL prefix and suffix can be
modified in the extension’s General Settings.
Choose to save form submissions in the back-end. By enabling this option, submitted form data can be
managed in the Form Submissions tab.
Enter a custom form submission ID prefix, which can be used as a reference for form submissions that
are saved in the back-end. By default the form ID is used as form submission prefix.
Enable the form to activate it in the front-end store.
If you chose to create a new page for the contact form, the front-end URL(s) will be displayed at the
bottom of the Form Settings tab after the form has been saved.

Front-end Style
In the Front-end Style tab you can:
Change the appearance of the contact form by choosing one of the 18 integrated Bootstrap themes, or
use your custom Bootstrap based store theme.
Select one of the six form wrapper styles or no wrapper.
Optionally enable the form title bar and enter a custom form title.
Set the maximum form width in pixels.
Choose to show the form field labels next to or above the input fields, or to hide the labels.
Enable RTL (Right-to-Left) text direction.
Modify the ‘success message’ which is displayed on the front-end when a contact form has been
successfully submitted.
Enter custom form wrapper CSS classes and add CSS rules to customize the form’s front-end style. To
customize specific form components, you can enter CSS classes per form field using the Form Builder
interface.

Custom Javascript
Using the Custom Javascript tab you can add arbitrary Javascript to be executed on page load, before or after
form submission.

Customer Notification
In the Customer Notification tab you can configure the e-mails that are send to the customer and optional
BCC recipients when a contact form has been submitted (if enabled).
You can also choose to use the default customer notifications settings.
By default, the recipient name and e-mail address will be fetched from the form input fields with ID
‘name’ (or ‘firstname’ + ‘lastname’) and ’email’. If these form field IDs are modified in the Form Builder tab
they need to be updated accordingly in the customer notification settings, by entering the ID preceded by
‘var’ and wrapped in double brackets, for example {{var customer_name}}.

The notification content supports the use of Magento®’s default store variables as well as custom contact
form variables, which can be used to automatically include submitted form data in your e-mail notifications.

Custom contact form variables can be added to the e-mail by wrapping the corresponding form field ID
preceded by ‘var’ in double brackets, for example {{var department}} or {{var contact-method}}. The
form field IDs can be configured in the Form Builder tab.

Admin Notification
In the Admin Notification tab you can configure the e-mails that are send to the admin and optional BCC
recipients when a contact form has been submitted (if enabled).
You can also choose to use the Default Admin Notifications Settings.

The ‘Conditional recipient(s)’ option can be used to send a copy of the admin notification to e-mail addresses
on condition that a specific form field value is submitted.
The conditional notification recipient can be configured by entering the form field ID and its conditional value,
followed by the recipient’s e-mail address.
Using the ‘Match Type’ dropdown menu you can choose whether the form field submission should exactly or
partially match the conditional value.

By entering the variable ‘form_url’ in the Field ID input field, you can set up conditional admin recipients
based on the front-end URL on which the contact form has been submitted. This can be useful when the
contact form is used on multiple store pages, such as a product questions form.

The ‘Reply to e-mail address’ is the recipient of replies to admin notifications, which by default is set to the
notification sender e-mail address. By using the variable {{var email}}, the submitted e-mail address from
the form field with ID ’email’ will be used as the reply recipient, making it possible to directly reply to the
customer.
The notification content supports the use of Magento®’s default store variables as well as custom contact
form variables, which can be used to automatically include submitted form data in your e-mail notifications.
Custom contact form variables can be added to the e-mail by wrapping the corresponding form field ID
preceded by ‘var’ in double brackets, for example {{var department}}. The form field ID’s can be configured
in the Form Builder tab.
The variable {{var submission_overview}} will include all submitted form data in the admin notification, plus
the front-end URL on which the form was submitted and the visitor’s IP address. These two values can also be
added to admin notifications individually using the variables {{var form_url}} and {{var visitor_ip}}.
Using the variable {{var uploaded_file_links}} you can display all uploaded files as links in the admin
notification e-mail. Alternatively, you can choose to attach uploaded files to the e-mail by enabling the
‘Include uploaded files as attachments’ option in the Default Admin Notifications Settings.

Translations
As of Custom Contact Forms v100.5.0, it’s possible to translate all form fields and notification e-mails for
each store view in the General Translations and Form Field Translations tab of the form view.

General Translations
The General Translation tab can be used to translate the front-end form title and success message and all
input values related to customer and admin e-mail notifications.
In this way you can specify the sender and recipient names, e-mail addresses, subjects and
notification content for each store view / language.
When a translation field is left empty, the default value will be used.

Form Field Translations
Using the Form Field Translations tab you can translate all front-end form fields and values including the label
text, options, placeholder text and default values for each store view.
When a translation field is left empty, the default value will be used.

Form Submissions
For each contact form you can choose to save its form submissions in the Admin Panel by enabling the ‘Save
form submissions’ option in the Form Settings tab.
Every time a contact form is submitted, the form submission will be automatically saved in the back-end,
where you can easily view its details and export submitted form data to CSV or Excel.
The forms submissions of a specific contact form can be managed in the Form Submissions tab of the form
view.

Alternatively, you can manage the form submissions of all your contact forms by navigating to Content >
Contact Forms > Form Submissions.

Select a form submission from the grid to view the submitted form data and copies of its customer and
admin notification (if enabled).

Creating Custom Contact Form Widgets
Contact forms can be inserted anywhere in your Magento® store by creating a custom contact form widget.
The contact form widget can be easily inserted in pages or blocks or displayed in specific layout updates as
further explained below.
The widget can be also used to create pop-up forms or slide-out forms.

Adding Contact Forms to Pages and Blocks
If you want to add one or multiple contact forms to a page or block, you can insert the form using a widget by
clicking the ‘Insert Widget’ button / icon above the content editor.
Please note that when using the Magento® Commerce PageBuilder module (Magento ® 2.3.1+), you’ll have to
add a ‘Text’ element first in which you can add the widget using the ‘Insert Widget’ button.
Select the the widget type ‘Custom Contact Form’ and click ‘Select Form’ to choose a contact form.
You can choose to insert a regular form, a pop-up or a slide-out form widget. Depending on the selected
display type you can configure additional pop-up or slide-out display options in the Widget Options section.
Click the ‘Insert Widget’ button to embed the form in a page or block.

This will add a widget code snippet / icon to the content editor, which can be moved to any desired place in
the page or block content to move the contact form.

Adding Contact Forms to Pages and Blocks using Widget Code
As an alternative to the method mentioned above, you can also add Custom Contact Form widgets directly in
CMS Pages and Blocks using the widget shortcode.
Regular Contact Form shortcode example:
{{widget type="PluginCompany\ContactForms\Block\Form\Widget\View" form_id="1" show_form_as="form"
type_name="Custom Contact Form"}}

Pop-up Contact form shortcode example:
{{widget type="PluginCompany\ContactForms\Block\Form\Widget\View" form_id="1" show_form_as="popup"
popup_max_width="600px" display_as_button="1" link_title="Contact us" wrap_in_block="0" auto_hide_popup="0"
type_name="Custom Contact Form"}}

Slide-out Contact form shortcode example:
{{widget type="PluginCompany\ContactForms\Block\Form\Widget\View" form_id="1" show_form_as="slideout"
auto_hide="0" slideout_position="left" title="Contact us" title_color="#FFFFFF" button_color="#EE6E73"
type_name="Custom Contact Form"}}

Adding Contact Forms to Layout Updates
If you want to add a contact form to a specific section of a page layout, such as a sidebar, footer or product
page block, you can create a widget using the Content > Widgets interface by clicking the ‘Add Widget’
button in the top right corner of the page.
Select the widget type ‘Custom Contact Form’ and your store’s design theme and click ‘Continue’.

In the Storefront Properties tab, enter a widget title for admin reference and select the applicable store
views.
Specify where you’d like to display the form in the Layout Updates section at the bottom of the Storefront
Properties tab.

Select a contact form in the Widget Options tab, where you can configure additional pop-up and slide-out
settings depending on the selected display type.

Save the widget and refresh the cache to add the contact form to the specified layout in your front-end
store.

Widget Options
When creating a contact form widget you can configure the front-end display options in the Widget Options
section / tab as further explained below.
Creating a Pop-up Contact Form
To create a pop-up form, follow the instructions for creating a custom contact form widget and choose the
display type ‘Pop-up Widget’ in the Widget Options section or tab.
In the Widget Options you can select a contact form, configure the maximum pop-up width, choose to display
a pop-up link or button and enter the link / button text.
If you’d like to display the pop-up link or button in a sidebar, you can optionally create a sidebar block and
customize its title and content.
Alternatively you can add the pop-up link / button to pages or blocks or specific layout updates.

Creating a Slide-out Contact Form
The Custom Contact Forms extension also includes a slide-out form widget, adding a button to the side of the
front-end store from where the contact form appears when clicked on.
To create a slide-out contact form, follow the follow the instructions for creating a custom contact form
widget and choose the display type ‘Slide-out Widget’ in the Widget Options section or tab.
In the Widget Options you can select a contact form and configure the position of the slide-out form widget.
Besides that you can customize the slide-out button text and colors.

Custom Contact Form Front-end Examples
Below you’ll find front-end examples of the various contact forms display options. Don’t forget to check out
the front-end theme showcase and custom contact form examples in our demo store for more inspiration!

Contact Form Page
Example of custom contact form in an automatically created form page.

Contact Form Embedded in Page
Example of custom contact form embedded in a store page using the contact form widget.

Contact Form Embedded in Product Page
Example of a product questions form embedded in a product page by adding the contact form widget to
a specific layout update.

Contact Form Sidebar Widget
Example of a sidebar widget with contact button, which displays the contact form in a pop-up when clicked
on.

Pop-up Contact Form
Example of custom contact form shown in a light-box pop-up using the pop-up form widget.

Slide-out Contact Form
Example of the a form appearing from the left side of the front-end store using a slide-out form widget.

Multi-page Contact Form
Example of multi-page contact form, which is divided into multiple pages or tabs with the Form Page
component. The top navigation bar automatically adjusts to smaller resolution screens if the form page titles
don’t fit on one line.

Multi-column Contact Form
Example of multi-column contact form, which is divided into multiple sections and columns using the Form
Section component.

