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Extension page: http://ecommerce.aheadworks.com/magento-extensions/product-questions.html
The Product Question extension enables your visitors to ask questions directly on the product page and receive answers
to them right there.

Installation
1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate
If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

2. Log in to the Magento backend

3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.
If Compiler status is Disabled, you can skip to the next step
If Compiler is enabled, disable it.
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IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you use
"Run Compilation Process" function, not just "Enable button"

Installing an extension with the Compilation enabled will result in store downtime.

4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:
via the backend:
Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:
On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

5. Download the extension package from your account and extract the downloaded archive

6. Copy the content of /Step_1/ folder to your store's root directory
If you are using a custom theme,
read the instructions here.
The extension comes with 2 design packages: /base/default/ and /rwd/default/ .
In case you are using a custom theme, it is recommended to copy the design files to your current theme's
folders. In case there are several themes in use at the same store, the design files must be copied to
each of them.
Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
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Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

7. Copy the content of /Step_2/ folder to your store's root directory

8. Flush store cache again; log out from the backend and log in again.

Set up cron
The Product Questions 2 extension relies on cron for sending out Ask Customers email. If you have already configured
cron jobs for your Magento installation then you can skip this step. Read the following instructions on setting cron job for
your Magento store: Magento user guide
Generally it would be enough to run in SSH console of your server:
crontab -e

And insert the following line:
*/3 * * * * wget -O - -q 'http://your-store.com/cron.php'

Don't forget to confirm saving request when exit.

Updating from 1.X branch
The Product Question 2 extension is a complete overhaul of the original idea. Compared to its predecessor, the 2.x
version has different code and data structure; therefore, to pass the data from the original extension to Product Questions
2, a special one-time procedure is required.
To import the existent data from the original Product Questions 1.X extension:
1. Install Product Questions 2 extension as per instructions above;
2. execute the migration script that comes with the 2.x version.
Open a browser and type in the address bar:

[www.your_domain.com]/shell/productquestion_update.php
After the migration script has been executed ("Complete!" message should appear), flush the store cache.
Then, you can disable and remove the original Product Questions 1.X module.

Inserting the Questions block in tabs
The extension automatically embeds its block in the Product View page via layout. If there is a need to move the block to
a tab, it can be done via layout as well.
Since the Magento themes are represented in great variety, the exact method may also vary. Below are 2 ready-made
examples, you can use them for reference.
The described methods are actual for Product Questions versions 2.0.1+
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Make sure you have fully performed the basic installation procedure (Steps 1-3 above) prior to moving the block.

RWD Theme
View details
1. Make sure you have copied the extension's layout file
( /app/design/frontend/base/default/layout/aw_pq2.xml ) to the RWD Theme folder (
/app/design/frontend/rwd/default/layout/ )
2. Open the "aw_pq2.xml" file and find the following string:

<reference name="product.info.additional">
<block type="aw_pq2/question_list" name="aw_pq2_question_list" before
...
</reference>

3. Replace this code part with the below one:

<reference name="product.info">
<block type="aw_pq2/question_list" name="aw_pq2_question_list" templa
<action method="addToParentGroup"><group>detailed_info</group></actio
<action method="setTitle" translate="value"><value>Product Questions
<block type="aw_pq2/question_form" name="aw_pq2_ask_question_form" te
<block type="aw_pq2/answer_form" name="aw_pq2_add_answer_form" templa
</block>
</reference>

4. Save the changes and flush the store cache

Ultimo Theme
The below instructions are for the popular Ultimo custom theme, but the similar method can be used for many other
custom themes as well.
View details
1. Open file /app/design/frontend/ultimo/default/layout/local.xml
2. Find the following string:

<block type="catalog/product_view_tabs" name="product.info.tabs" as="info_tab

3. Insert the below code after it:

<remove name="aw_pq2_question_list"/>
<action method="addTab" translate="title"><alias>aw_pq2_question_tab_list</al
<block>aw_pq2/question_tab_list</block><template>aw_pq2/catalog/product/v
</action>

4. Save the changes and flush the store cache.
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Configuration
General Settings | Interface Settings | Notification Settings
The extension's general settings can be found in System -> Configuration -> aheadWorks Extensions -> Product
Questions 2 (or Catalog -> Product Questions -> Settings)
General Settings tab:
Enable Product Questions 2 - switches on / off the
extension's frontend functionality
Who Can Ask Questions from Product Page - this
option defines if questions can be submitted by
Registered Customers only, or by Anyone (i.e., both
registered clients and guests)
Who Can Answer Questions from Product Page defines what customers are allowed to answer the
questions. Available values are:
Nobody (admin only) - customers cannot
answer questions
Any Registered Customer - only logged in
customers can answer questions
Only Registered Customers Who
Purchased The Products - answering is
allowed for logged in customers who have
previously ordered the current product
Anyone - any store visitor can answer the
questions
Approve Answers Automatically (yes / no) - defines
if a store admin's approval for customer-submitted
answers is required, or they will get "Approved" status
automatically.
Do not send "Ask Customers" emails to
customers who bought product more than X days
ago - excludes the customers whose orders were
placed earlier that X days ago from the "Ask
Customers" recipients.
Guests can rate helpfulness (yes / no) - allows /
prohibits voting for guest users
Subscribe customers to Product Questions
emails automatically (yes / no) - defines whether a
customer will be automatically subscribed to
extension's emails
How can I manage customers' subscriptions?
You can manually subscribe or unsubscribe your
clients on per-customer basis. Open Edit
Customer screen, switch to Product Questions
tab, and select / de-select the required
notification types.

Customer-defined question visibility (Private or
Public) - enables / disables customers to choose the
type of their question. Public questions will be
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displayed in the frontend, while Private questions will
be answered via email only.

Interface Settings tab:
Number of questions to display - this option defines
how many questions will be shown under the 'Product
Questions' section at the product page. If the actual
number of questions exceeds this value, the rest will
be hidden under an expand link.
Number of answers to display - this option defines
how many answers will be shown under a question by
default. If the actual number of answers exceeds this
value, the one(s) with the lowest Helpfulness rating
will be hidden under an expand link.
Display URLs as links - this option defines whether
URLs posted in questions and answers will be parsed
to clickable links, or will be represented as a plain
text.
Default questions sort by - this option defines the
default sorting type for questions, whether by date or
by helpfulness.
Default sort order - this option defines the sort order
for questions, whether descending (the most
recent/helpful questions at the top of the list) or
ascending (less recent/helpful questions at the top of
the list).

Notification Settings tab:
In this tab, you can configure the notifications settings of the
extension. You are to specify the recipient of all the adminside notifications ( Send admin notifications to this
email address option ), Email Sender and select the email
template for each of the listed notifications type.
You can disable any of the Notification Types by
choosing "Do not send" in the template selector
How do I edit these email templates?
The Product Questions 2 extension adds a
number of email templates to
app/locale/en_US/template/email/ folder; all the
module's templates start with aw_pq2_* prefix.
You can edit any of those templates, and create
your custom ones as well.
NOTE: the extension also supports
Transactional Emails - you can create / edit
templates through System->Transactional
Emails backend grid
There is a number of variables available for the
extension's emails.

Variable code

Description

var customer_name

displays the
name of the
author, works
for both
Questions
and Answers
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Variable code

Description

var question_initiator_name

returns the
name of the
question's
original poster

var product_name

displays
product name

var product_url

returns the
link to the
product page

var new_answer_status

returns the
status of the
submitted
answer

var question_text

returns the
text of the
question

var answer_text

returns the
text of the
answer

var points_amount

displays the
amount of
reward for
answering*

var
points_registration_amount

displays the
amount of
reward for
store signup*

var unsubscribe_link

returns link to
Manage
Product
Questions
Subscription
page

var web_version_link

returns the
link to the
Web Copy of
an email

var
product_answer_please_url

returns the
link to the
product page,
automatically
logs in the
customer

var
backend_question_page

returns the
link to the
backend
question page

*Variable will work only if the Points &
Rewards extension is installed at the store.

There's also a number of directives for use in IF
... constructions
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Directive

Condition

var
is_registered

Author is a registered user

var is_guest

Author is a guest user

var
is_approved

Question or Answer is
approved

var moderate

Answers Auto-Approval is
disabled

Remove Email Web copies older than X days option sets
the delay before the web copies of an email are removed.
What does it mean?
The Product Questions extension stores the web
copies of all the emails sent through the module.
In case the recipient's mail agent or service strips
the html formatting, images, etc., they have a
possibility to view an email in their browser, as a
regular web page. A dynamic link to the Web
View can be inserted into the outgoing emails
(this link is present in all the default templates).

Managing questions
You can view and manage customer's questions via Catalog -> Product Questions -> All Questions backend grid. A
quick link for unprocessed questions is also available, Catalog -> Product Questions -> Pending Questions.
New questions can be created by the store admin as well, through the same grid. An Admin user should just click Add
New button, select the desired product and the frontend customer account (Guest option is also available), and fill out the
question form.

Question view screen
General | Manage Answers | Sharing Question
General tab:
Linked Entity - this field contains a clickable link to
the product the question is associated with
Asked From - this field shows the storeview origin of
the question
Created At - shows the question creation date; can
be altered.
Show in stores - allows sharing the question to any
other storeviews.
Status (Pending / Approved / Declined) - defines the
question status. Only "Approved" questions show up
in the frontend.
Author Name and Author Email - can be edited for
a guest question. For a question submitted by a
registered user, these fields are replaced with a single
http://confluence.aheadworks.com/display/EUDOC/Product+Questions+2
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Author record with the clickable link to the customer
account.
Question - the actual inquiry text; can be edited by
the admin.
Visibility (Private / Public) - defines the type of the
question. "Public" questions will be posted in the
frontend, "Private" ones will only receive admin's
answers via email.
Helpfulness - shows the question rating; can be
altered by the store admin.

Manage Answers tab:
Through this tab, you can manage all the submitted
answers, and add new ones.
Mass actions (Change Status / Delete) are allowed in this
grid.

Sharing question tab:
The Product Questions extension allows sharing a given
question between multiple products.
There is total of 4 available sharing modes:
Product(s) - you will be able to manually select the
target item(s) from the grid
Attribute Set - the question will be shown for every
item of the selected Attribute Set
Website - the question will be visible on all the items
within the selected Website. Hint: if you would to
share a question within a certain Storeview only, use
Website sharing in conjunction with Show in
stores option.
Global - the question will be displayed on every
product within your Magento.

Answering questions
After "Add New" button is clicked in View Question ->
Manage Answers tab, the answer form will open in a popup.
The first step is to define the answer origin (Admin,
registered Customer or guest).
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Note: this selection step serves convenience
purpose mostly. The identical set of answer options
will be available independently from this choice, it
will only affect the default values.

Next step is filling our the actual answer form.
Author Name and Author Email fields will be replaced with
a clickable link to the Customer View screen if the answer is
posted by a registered user. Answer Date and Helpfulness
rating can be altered by the store admin.
Is Admin's Answer (Yes / No) option will mark the answer
as posted by admin in the frontend. Note: the "admin
answer" mark can be given to any answer, even posted by a
guest visitor or registered user.
Status option defines the answer state. The new answers
receive "Pending" status by default (unless Approve
Answers Automatically option is enabled), "Approved"
questions will be posted in the frontend; if an answer is
"Declined", it won't appear in the frontend.

Ask Customers option
This function allows a store admin to send out notifications
about a question posted for a product.
These notifications will be sent to the customers who have
previously purchased this particular product (but not earlier
than X days before). By default, these notifications contain a
link to the product page with the automated customer login
procedure.
The figure in brackets on the button indicates the number of
recipients.
The emails are sent each time the Ask Customer button is clicked, to ALL the eligible recipients. Multiple button
clicks may result in your customers' receiving duplicate emails.
To avoid such situation, you may want to set Do not send "Ask Customers" emails to customers who bought
product more than X days ago restriction in General Settings of the extension.

Custom position via Widget
In addition to the default position, the extension allows placing Product Questions block manually via Widget.
When the new Widget is added you will first need to specify
the 'Type' as 'AW Product Questions 2' and the 'Design
Package/Theme' you currently have at your store.
Product Questions 2 widget is not affected by the
general extension sorting settings.
http://confluence.aheadworks.com/display/EUDOC/Product+Questions+2
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The questions are displayed in a widget according
the helpfulness rating - the most helpful are
displayed first.
Frontend properties of the Widget come as usual with the
Widget's general settings.
'Widget Options' section allows specifying the
number of questions to be displayed in a Widget in a
'Public answered questions' field.
Note, 'Public answered questions' option overrides
the general Product Questions extension setting
'Number of questions to display'.
One can also use the following Widget declaration:

{{widget type="aw_pq2/widget_block" num_questions="5"}}
Where num_questions="N" - is the number of questions that should be displayed in the widget.

Integration with other aheadWorks extensions
The Product Questions 2 extension is integrated with Points & Rewards (since 1.7.3 version) module. If both
extensions are installed at the store, you will be able to reward customers for answering questions.
Help Desk Ultimate 3 - if both extensions are in use at the same store, you will have an option to convert a product
question to a help desk ticket.

Uninstallation
If you just need to temporary disable the extension, you can just do the steps 1-5, without deleting the files of the
extension.
Disable compilation, in case it is enabled.
Login to your FTP, navigate to app/etc/modules/
Open the file AW_Pquestions2.xml and change the following line:
<active>true</active>

to
<active>false</active>

Now your Magento is unaware of the existence of this module.
Clear the cache under var/cache
Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.
If everything works fine, it is safe to delete the files of the extension.
In case you need to clean the database, backup your database and then run the following queries in MySQL:
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TABLE
TABLE
TABLE
TABLE
TABLE
TABLE

IF
IF
IF
IF
IF
IF

EXISTS
EXISTS
EXISTS
EXISTS
EXISTS
EXISTS

`aw_pquestion2_summary_answer`;
`aw_pquestion2_notification_queue`;
`aw_pquestion2_notification_subscriber`;
`aw_pquestion2_summary_question`;
`aw_pquestion2_answer`;
`aw_pquestion2_question`;

delete from core_resource where code =`aw_pq2_setup`;

Note, if you are using the table with prefixes, you must specify them in all table names.
If you are not sure how to do that or expect any troubles with it, please contact your server administrator regarding
the matter.
If you remove the tables as it is described above, you will need to configure the extension again when it is
reinstalled. All questions and answers will be lost as well.

Troubleshooting
After the extension installation the store gives an error, or blank page, or suggests to start Magento installation
procedure.
Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear
the store cache and try again.
There is no aheadWorks extensions under my configuration section, or having the extension tab clicked I get a
blank page, or Access Denied error.
Clear the store cache, browser cookies, logout and login again.
My configuration changes do not appear on the store.
Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com
License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt
Contact us: http://ecommerce.aheadworks.com/contacts/
Copyright © 2015 aheadWorks http://www.aheadworks.com
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