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As many as 78% of customers cite "Customer Support" as the # 1 factor when choosing a merchant or a provider on the
internet. That's what we found out in our recent study on factors influencing consumers' online buying behaviour. An
efficient customer support, case tracking and resolution system is indispensable for a successful e-commerce business.

The Help Desk Ultimate Magento extension, developed after taking on board the lessons we've learned on online
shopper behavior, is the perfect customer care and support solution for your Magento-based e-commerce site.

 

Installation

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation

Having hard time finding
an answer to your
question?

Check out our
Knowledge Base.

http://confluence.aheadworks.com/display/EUDOC
http://confluence.aheadworks.com/display/EUDOC/Documentation+Home
http://confluence.aheadworks.com/display/~malynow
http://confluence.aheadworks.com/pages/diffpagesbyversion.action?pageId=20349611&selectedPageVersions=23&selectedPageVersions=24
http://confluence.aheadworks.com/display/EUDOC/Help+Desk+Ultimate+3
http://ecommerce.aheadworks.com/magento-extensions/help-desk-ultimate.html
http://ecommerce.aheadworks.com/kbase/extension-help-desk-ultimate-3/
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Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you use
"Run Compilation Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

 5. Download the extension package from your account and extract the downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

Installing an extension with the Compilation enabled will result in store downtime.

If you are using a custom theme,
read the instructions here.
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 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

Set up cron
The Help Desk Ultimate extension uses cron for message processing. Read the following instructions on setting cron job
for your Magento store: Magento user guide. If you have already configured cron jobs for your Magento installation then
you can skip this step.

Generally it would be enough to run in SSH console of your server: 
crontab -e

And add the following line: 
 

*/3 * * * * wget -O - -q 'http://your-store/cron.php'

 
Don't forget to confirm saving request when exit.
The recommended Cron execution frequency is 3-5 minutes. 
 
Once cronjob is set up and running, the extension will be saving every action in the log, which can be viewed in System-
>Configuration->aheadWorks Extensions->Info->aheadWorks Extensions logging->View log. If you think that the
extension does not work as expected, it is recommended to check the log first. If it is empty or contains very few records,
it may indicate that your cronjob is not set or set improperly. Normally, every cron launch should add 1 or more entries.
Actual quantity of the entries depends on the number of processed events per given cronjob.

Migration from HDU 2.10.11
The 3.x branch of the Help Desk Ultimate extension has been completely reworked, it has deep structural, coding and
workflow differences from its predecessor. Therefore, the new version will not have access to the data of the older
versions immediately after the installation.

To import the data into the HDU 3 extension, we have prepared a special migration script. See details on how to use it
below.

In case you are using a custom theme, it is recommended to copy the design files to your current theme's
folders. In case there are several themes in use at the same store, the design files must be copied to
each of them.

Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

The migration script can only transfer the data from 2.10.11 version to 3.x branch. If you are using an older
version, you will need to update to 2.10.11 first, then install the 3.x version and execute the script.

How to use the migration script?

Make sure to backup your DB before starting the migration
Make sure that there is no tickets-related activity (updates, etc) while the migration is
performed. If a ticket gets updated during the migration, the latest changes may be lost. 
Disable all the active gateways through the original module's backend menu 
You may also want to disable the original module in System-> Configuration-> Advanced->

http://merch.docs.magento.com/ce/user_guide/Magento_Community_Edition_User_Guide.html#system-operations/cron.html#kanchor1045
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The sequence of actions required for a successful migration is as follows:

1. Install the Help Desk Ultimate 3 extension as per instructions above
2. Make sure the extension is disabled via its General Settings (System-> Configuration->

aheadWorks Extensions-> Help Desk Ultimate 3-> General Settings-> Enable Module set to "No")
3. Execute the migration script either manually (from the browser address bar), or via cron: 

your_store.com/shell/helpdesk3_update.php 

 
4. The migration script writes the output log file, which indicates the progress: var/aw_hdu_migration.log 

The content of this file looks like this: 

(2) from (2)  department(s) has been replaced 
(0) from (0)  status(es) has been replaced 
(3) from (3)  pattern(s) has been replaced 
(0) from (0)  template(s) has been replaced 
(46) from (46)  mail(s) has been replaced 
(7) from (7)  message(s) has been replaced

5. The migration can be considered complete if all the log records indicate full processing ( (X) from (X)
has been replaced ), or if manual script run returns "Already completed!" message

 

6. Once migration complete - from the Magento root folder at your FTP proceed to: /app/etc/modules/

Open the file AW_Helpdeskultimate.xml and change the following line:
 

<active>true</active>

to

Disable Modules Output tab, to prevent ticket updates. DO NOT disable the original module
via .xml config file. 

To avoid excessive server load, deliberate execution limitations were introduced into the script.
It processes limited number of entities per execution:

100 tickets (initial ticket messages + ticket details)

100 messages

100 emails

Thus, if there are more records of the above types at your store currently, you will need to run
the script multiple times

For the remaining entities (Departments, Templates, etc) are processed without any limitations,
i.e., these records should normally be passed in their entirety during the 1st script run

For advanced users
Depending on your server capabilities, you may want to adjust the processing limits. To do, you can
edit the following file:

/app/code/local/AW/Helpdesk3/Model/Shell/Migration.php

The target parameters are:

REPLACE_MAILBOX_LIMIT  
REPLACE_TICKET_LIMIT  
REPLACE_MESSAGE_LIMIT 
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Please verify email templates after migration, as templates of the previous versions will be removed.

Configuration

General Settings
The extension's general parameters can be configured in System -> Configuration -> aheadWorks
Extensions -> Help Desk (or, Help Desk -> Settings) backend page.

General Settings tab:

Enable Module - activates the extension

Primary Department - this option allows
selecting the Primary Department, which will
be default for new tickets if the manual
departments selection is disabled for
customers.
Ticket auto-experation, days - sets the time
period before a "Waiting For Customer" ticket
is automatically closed. (see more info about
the ticket statuses here)
Gateways: Create new tickets from
incoming emails - enables / disables parsing
incoming emails into tickets (more info on
gateways functionality here)
Hide "Customer Orders" from Agents -
hides the Latest Orders section from the
specified users in the Ticket View screen. The
available modes are: 

Hide from all Agents
Hide from all Agents except Primary
Agents
Don't hide

Send carbon copy to - sends a copy of every
ticket update to the specified email(s)
Display these columns in tickets grid - this
multi-select field allows customizing the
content of View Tickets grid by
including/excluding certain columns
Enable Ticket Rating - this option allows your
customers to rate tickets. Customers can rate
from email or Customer Account page during
15 days after last change of the ticket status
Enable Product Questions Integration -
enables/disables integration with Product
Questions 2 extension.

 

<active>false</active>

You must select a Primary department
(see option below) in order to be able
to activate the extension.

How does Product Questions 2
integration work?

If the integration is enabled, the
new questions asked via the PQ
frontend form will be parsed to
tickets. The subject of such a ticket
will clearly indicate that it was
generated from a Product

http://ecommerce.aheadworks.com/magento-extensions/product-questions.html
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Frontend tab: 

Show these fields when customer creates
ticket - defines whether Department Selector,
Priority Selector and Order Selector fields will
be displayed on "Submit Ticket" form
Allow customer to attach files - allows /
prohibits attaching files to messages. This
option works for web-form ticket submissions;
the email attachments are controlled in the
Gateway settings
Max Upload File Size (Mb) - restricts the
maximum attachment size
Allow file extensions - restricts the file
extensions that are allowed for attaching. Use
commas to list multiple extensions
Enable Contact Form integration - enables
submitting tickets through the native Contact
form. If this option is enabled, any message
posted through the contact form will be parsed
to a ticket; otherwise, the form submissions will
be processed per standard Magento scenario;
Disable standard contact form emails -
disables native Magento contact form
notification emails and uses the Help Desk
Ultimate's ones instead;
Allow external view for tickets -
enables/disables external view option

Show selected entities to customer on
ticket page - shows or hides the
correspondent attributes from the ticket thread.

 

Ticket Escalation tab:

 

Allow ticket escalation - enables / disables
the Escalate functionality
Supervisor email(s) - the email address (-es)
the escalate messages will be sent to
Email Template to supervisor - the email
template that will be used for escalation
notices.

 

 

Question, and the Content area will
contain links to the product (both
frontend and backend ones).

What Is "External URL"?
External View Link is a long
encrypted URL which allows to
access the ticket thread without
being logged in to a store account.
This link is crucial in case you allow
guest submissions, but do not use
the Email Gateway functionality.

How does it work?
The escalation option may be useful for
ensuring the high quality of customer
service.

If this functionality is allowed, a customer
can sent a complaint or comment regarding
an open ticket directly to store supervisors,
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Managing Departments
The extension allows creating unlimited number of Departments. You can view the existent ones and create new
through Help Desk -> Departments backend grid.

Here's how the department setup looks like.

General tab allows specifying basic department
parameters:

Status - Enabled / Disabled
Visible on (select Storeview(s)) - this selector
allows choosing on what storeviews the
department will be selectible in the forms

Title - defines the Department name both for
frontend and backend usage
Sort Order - define list position of the
Department

 

 Notification Settings tab:

Through this tab, you can define the Sender of the
extension's email notifications, and select the template
for each of the listed notification types. The following
events can trigger notifications:

Event Triggered
By

Sent to

New Ticket Customer Support
(Department
Primary Agent)

Customer

Support Customer

New reply Customer Support
(Currently
Assigned Agent)

Support Customer

Ticket re-assignation Support Department
Primary Agent

 

bypassing the current department and
agent.

If the Escalate option is invoked, a customer
will have an option to submit the special
message, which will be sent to the email(s)
specified in the extension configuration.

This option defines frontent visibility
status only. Any active department can
still be assigned tickets to even if it is
invisible for the ticket's original
storeview.

To learn more about the extension's email
templates, check this section
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New Assignee

Ticket re-assignation
or status update

Support Customer

 

To disable a given notification type, just set "Do not
send" in the template selector.

Help Desk Agents tab:

Here, you can select Agents (i.e., Admin Users)
associated with the department. You are also to select
the Primary User.

Note, while a department can have any number of
associated Agents, there can be only one Primary User
per department.

 

Email Gateway tab:

The Help Desk Ultimate extension allows submitting
tickets via email, this functionality is implemented via
the support of Email Gateways. A gateway is a
dedicated mailbox, which is meant to be used by the
extension exclusively. The module will consider every
message that goes through that mailbox either a ticket
reply or a new ticket. A separate gateway can be
created for each of the departments.

By default, the Gateway functionality for a department
is disabled. Once you set Enable Email Gateway
option to "Yes", the mailbox configuration options will
get displayed.

To set up a gateway, you should specify the below
values:

Title
Protocol ( IMAP / POP3 )
Gateway Email
Gateway Host
Login and Password
Port - make sure that the specified port is
opened in your server's firewall settings,
otherwise, the extension will be unable to
connect to the gateway
Use SSL / TLS
Delete Emails From Host - this option defines
whether an email will be removed from the
gateway mailbox after it gets parsed to ticket
Allow file attachments - enables / disables
accepting attached files.

 

Use Test Connection button to quick-check if settings
are correct.

 

The Agent names are taken from the backend
user account, and can be specified in System -
> Permissions -> Users

When setting up a gateway, make sure that the
selected mailbox does not have any messages
in the Inbox folder.

If the Inbox folder is not empty, move its entire
content to a different folder.
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Admin Permissions tab:

 

Through this tab, you can set the access restrictions for
the tickets assigned to the department.

Allowed for Departments selector - here ,
you can select the existent department(s); all
the Agents associated with the selected
departments will have access to the
department tickets.

Allowed for Roles selector - allows defining
what Admin Role Scope (s) are allowed access
to the department tickets.

 

 

Managing Tickets
The tickets can be viewed and managed through Help Desk - > View Tickets backend grid. Here is how this grid
looks like:

This grid can be sorted / filtered by any of the columns. Pay attention to the following options available from the grid.

Export - the extension allows exporting the grid in its current state (i.e., with filtering and sorting applied) to
a .csv or .xml file. 

Search - the extension can search the Subject of the ticket and its full content for the query words. 

The selector will not contain the currently set-
up department; it lists other departments
present in the system.

Make sure to select at least one department
or admin role here. By default, all the entries
are de-selected, if the department is saved
without any role scopes marked, the tickets
assigned to this department will not be
accessible from the backend.

Note: the search "stacks" with the currently applied filtering. E.g., if you filter the grid by an Agent
and run search, the latter will be conducted among the tickets currently assinged to the selected
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Actions - mass actions are supported. Here's the list of Actions you can apply from this grid: 
Assign to Department
Assign to Agent (Note: if the new assignee belongs to a different department, the dept assignation
will be automatically updated as well)
Change Status
Change Priority
Delete

 

Action - manage ticket in the popup window

 

agent only.

Creating new tickets
The extension allows creating tickets from the backend. There are several areas a new ticket can be created
from.

From the View Tickets grid via the Add Ticket button
From the Customer Account details page via the Create Ticket button
From the Order View page via the Create Ticket button

From Order Details page

View details
The extension adds a special tab into the backend customer account, where all
customer's tickets are listed. New ones can be created from this tab as well.

View details
New tickets can be created via the Comments section in backend Order View page.



08.08.2017 Help Desk Ultimate 3 - Documentation - Confluence

http://confluence.aheadworks.com/display/EUDOC/Help+Desk+Ultimate+3 11/20

 

Ticket Attributes
A ticket has a number of basic properties and parameters:

Ticket ID - is assigned to a ticket automatically on submission. Has a format like "ABC-12345". The ID
serves a number of crucial purposes, the main one is properly associating email ticket updates with the
ticket thread. Ticket ID MUST be kept in the subject line if a ticket is replied to directly via email. 

Status - the parameter introduced to ease managing the workflow. Technically, all statuses except "Closed"
(including the Custom Statuses you might have created) are identical, and can be used for filtering the View
Tickets grid. Status "Closed" prohibits further updates from the customer side - the ticket thread can still be
viewed, but submitting any new messages to that particular ticket is disabled. NOTE: a "Closed" ticket can
still be re-opened by the store admin.

 
Priority - the parameter introduced to ease managing the workflow. Has 4 default values, can be used for
filtering the View Tickets grid.

 

 

Or at the Help Desk Tickets tab where the quantity of tickets is displayed within the
brackets.

Customization
Custom values are supported for both Status and Priority. Custom Status(es) and Priority (-ies) can
be created and managed through Help Desk -> Customization backend menu entry
(Statuses and Priorities shortcuts respectively.)

How do I customize them?

While setting up a Status and a Priority values,
the identical set of options is available:

Status - enabled / disabled
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Department and Agent assignation - one of the key ticket parameters. All the notifications and replies will
be sent to / from the department the ticket is currently assigned to. If frontend department selector is
enabled, a customer will have an option to choose the desired department during the ticket submission.
After the ticket is created, department assignation can be changed by admin users ONLY.  

Ticket Lock (yes / no) - this function restricts updating a ticket to the current Agent. If Ticket Lock is on, only
the current Agent can respond to, and change other parameters (Priority, Status, etc) of a given ticket. 

Customer Assignation - one of the key ticket parameters. Defined automatically for logged in users, must
be manually specified by guests. NOTE: if a registered user submits a ticket as a guest, but specifies their
account email address, it is possible to link the ticket to their account. 

Order Assignation (optional) - links a ticket to an order; using this function allows opening the order screen
directly from the Edit Ticket screen, and, lists the ticket in the Help Desk tab in the View Order page. 

 

 

 

Replying to a ticket 

From the backend

Font and Background Color - these
options allow adjusting the entry
appearance

The Manage Titles section below allows
specifying text labels for each of the storeviews.

NOTE: Both Status and Priority attributes have 4 default values. These values can be customized,
but CANNOT BE deleted or inactivated.

Removing entities
Since version 3.1.0 , the extension allows removing (disabling / deleting) certain entities. Doing so does not affect
the ticket history - if any of the removed entities was associated with a given ticket, it will still be displayed in the
ticket thread.

 
Restrictions

There are certain restrictions for removing the entities:

Entity The entity cannot be deleted if it: The entity cannot be disabled if
it: 

Department 1) is set as «Primary Department» 
2) has tickets assigned to it

1) is set as «Primary Department»

Agent 1) is set as «Primary Agent» for any
department 
2) has tickets assigned to them

1) is set as «Primary Agent» for any
department 
2) has tickets assigned to them

Status 1) is «System Status»  
2) is assigned to any ticket

1) is «System Status»

Priority 1) is «System Status» 
2) is assigned to any ticket

1) is «System Priority»
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Once you open a ticket from the Help Desk - > View Tickets grid, you will get to the Ticket Details screen. It is
divided into 3 sections.

The right sidebar contains a number of subsections,
which provide additional information and facilities for
processing the ticket.

 

Details section represent basic ticket attributes (as
explained above):

Help Desk Agent - current assignee
Department - current department
Status
Priority
Order
External View - you can copy the External
URL from here
Rate - ticket rating, specified by the customer

 

Customer Summary section contains customer-
related info:

Customer - Name and Email address (for a
guest user, Email only)
Country - for registered customers only
City - for registered customers only
Phone - for registered customers only
Customer Note - this is a special note that can
be added by the agents; this record will not be
visible in the frontend, and will be displayed in
all the ticket from a given customer.

 

The Last Customer Orders section provides summary
on customer's most recent purchases (up to 5 records)

The Last Customer Tickets section provides summary
on customer's most recent tickets (up to 5 records)

 

The Reply section:

What Is "External URL"?
The External View link is a long
encrypted URL, which allows to
access the ticket thread without
being logged in to a store account.
This link is crucial in case you allow
guest submissions, but do not use
the Email Gateway functionality.
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there's where you actually reply to the ticket. This
section consists of the text area (with switchable
WYSIWYG editor) and the file attachment option.

The Use Quick Response option allows inserting pre-
defined text shortcuts

 

The New Status selector and the Reply button - after
you click Reply, the message will be submitted to the
ticket (and the email will go out to the customer), the
ticket status will be set to the selected one.

The Ticket Thread section:

It contains the communication history. There are entries
of 3 types - Message (shown in the Discussion tab),
Notes (invisible to customers, can be posted by admin
users at any time), and System Events (Status/ priority
changes, re-assignation, etc; displayed in the History
tab).

The "All" tab includes the entries of all types.

Quick Responses
The extension allows storing pre-made
reply templates that can be pasted into a
ticket reply. You can manage these
templates in Help Desk -> Quick
Responses grid. 

Basically, creating a Quick Response only
requires specifying Status (Enabled /
Disabled), Title and Content. The
Storeview selector allows distributing the
Quick Responses between the existent
storeviews. 

After a Quick Response is saved, it can be
pasted to the Reply message.

How will it look like if I switch to "All" tab?
Note, the color coding implemented in
the extension. Messages from the
customer and the agent, system
messages and Agent notes are
highlighted with different colors.
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Via email

Both the customer and the store admin has a possibility to reply to a ticket via email bypassing the module's
webform. This functionality is only available if the email parsing is enabled and the email gateways are setup.

To reply to a ticket via email it is enough to respond to any ticket-related notification. Such response will be parsed
into the Help Desk and attached to the ticket thread given the following conditions are met:

The response is sent to the gateway email address. If an email is send directly to customer's / admin's
address or to any other destination, the ticket will not get updated.
The ticket ID ( ABC-1234 ) is kept in the subject of the email. If the message subject gets altered and the
ID is removed, the response will not get attached to the existent thread; a new ticket will be open instead.

 

E-mail variables and templates

The extension comes with a number of pre-defined templates for all the module's notifications tab. Beside these
default ones, you can use any template created via System-> Transactional Emails. 

The default templates can also be amended via the Transactional Emails grid, they all have "AW Help Desk 3 * "
prefix:

 

The Help Desk Ultimate extension allows using a number of variables in outgoing emails (see the list below).

These variable can be used both in department notifications templates and in actual messages.

Variables:

For HDU 2.10.11 users
The 3.x branch of the extension has different set of the email variables. If you are planning to keep using the
existent email templates with the new version, make sure to replace the "old" variables with the new ones.
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Code Description

{{var ticket_uid}} ticket ID

{{var ticket_subject}} ticket subject

{{var ticket_priority}} ticket current priority

{{var ticket_status}} ticket status

{{var ticket_created_at}} ticket creation date

{{var ticket_first_message}} content of the 1st ticket message

{{var message}} content of the latest relevant message

{{var customer_name}} customer's full name

{{var customer_first_name}} customer's first name

{{var customer_email}} customer's email address

{{var department_title}} the title of the current department 

{{var agent_name}} the name of the current agent

 

Additional facilities

Statistics
The 3.0+ version of the extension features reporting system that allows estimating the effectiveness and the quality
of the service. There are 3 types of reports, available through the Help Desk -> Statistics backend menu entry.

Workload Report

This report is meant to give the instant idea of the current load level of the support team. The report lists total
number of ticket per-department and per-agent. The tickets are summarized by status and by priority.

E.g., an Open ticket of Urgent status will add +1 in 3 columns: New and Open Tickets, Open Tickets and Urgent
Tickets.

 

The report can be exported into a file; .csv and .xml output formats are supported
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Agent Statistics

This report is aimed at estimating the effectiveness of support Agents. It calculates the Average First Response
Time and Average Ticket Closing Time parameters per-agent. The Graph can be switched to represent either First
Response or Closing times.

Ticket Status Statistics

Calculations
There are 2 important facts about how the average values are calculated:

a. For more accurate statistics calculations, the extension uses Median method. You can learn more
about this method from Wiki article.

b. The First Response Time is counted since a new ticket is submitted and until it acquires a first
response from a Help Desk agent.

The report can be exported into a file; .csv and .xml output formats are supported

http://en.wikipedia.org/wiki/Median
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This report shows the dynamics of ticket status changes. It represents the number of ticket that obtained any of the
selected Statuses within the reporting period. The graph is built per-department.

E-mail Rejecting
The Help Desk Ultimate extension allows setting up automated
spam filters. If Header, Subject or Body of an incoming email
contains some specific text, this message can be blocked. To
configure the email spam filters:

Navigate to Help Desk-> E-mail Rejecting-> Manage
Patterns.
Specify pattern based on regular
expression: http://en.wikipedia.org/wiki/Regular_expression
Specify 'scope' of e-mail, which would be validated by
pattern.

 

You can also view all the rejected emails in Help Desk -> Email Rejecting -> Rejected Emails grid.

 

Uninstallation 
If you just need to temporary disable the extension, you can just do the steps 1-5, without deleting the files of the
extension.

a. Disable compilation, in case it is enabled.
b. Login to your FTP, navigate to app/etc/modules/
c. Open the file AW_Helpdesk3.xml and change the following line:   

 

<active>true</active>

to   
 

<active>false</active>

Now your Magento is unaware of the existence of this module.
d. Clear the cache under var/cache
e. Make sure that the site is working properly, otherwise roll back the changes and apply to our technical

support.

http://en.wikipedia.org/wiki/Regular_expression
http://ecommerce.aheadworks.com/contacts/
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f. If everything works fine, it is safe to delete the files of the extension. 
In case you need to clean the database, make a backup and then run the following query in MySQL: 
 

DROP TABLE IF EXISTS 'aw_hdu3_customer_note'
DROP TABLE IF EXISTS 'aw_hdu3_template'
DROP TABLE IF EXISTS 'aw_hdu3_department_agent_link'
DROP TABLE IF EXISTS 'aw_hdu3_department_notification'
DROP TABLE IF EXISTS 'aw_hdu3_department_permission'
DROP TABLE IF EXISTS 'aw_hdu3_gateway_mail_attachment'
DROP TABLE IF EXISTS 'aw_hdu3_gateway_mail_reject_pattern'
DROP TABLE IF EXISTS 'aw_hdu3_gateway_mail'
DROP TABLE IF EXISTS 'aw_hdu3_gateway'
DROP TABLE IF EXISTS 'aw_hdu3_migration_temp_data'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_status_label'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_priority_label'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_message'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_history_additional'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_history_attachment'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_history'
DROP TABLE IF EXISTS 'aw_hdu3_ticket'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_status'
DROP TABLE IF EXISTS 'aw_hdu3_ticket_priority'
DROP TABLE IF EXISTS 'aw_hdu3_department'
DROP TABLE IF EXISTS 'aw_hdu3_department_agent'
DELETE FROM core_resource WHERE code = 'aw_hdu3_setup'

 

Note, if you are using the table with prefixes, you must specify them in all table names.  
If you are not sure how to do that or expect any troubles with it, please contact your server administrator
regarding the matter. 
If you remove the tables as it is described above, you will need to reconfigure the extension completely
again after the extension is reinstalled (department/gateway details, etc). All conversations history will be
lost as well.

Troubleshooting
After the extension installation the store gives an error, or blank page, or suggests to start Magento
installation procedure.

Change the owner of the extracted extension files to the web server user and set 775 permissions on them.
Clear the store cache and try again.

After the extension installation I receive a 404 error in System->Configuration->Help Desk Ultimate.

Logout from backend and login back. 

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked I
get a blank page, or Access Denied error.

Clear the store cache, browser cookies, logout and login again.

I've set up everything correctly, inserted the HTML code but there is nothing on that page.

Clear the store cache, clear your browser cache and domain cookies and refresh the page.

My configuration changes do not appear on the store.

 Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com 

License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt 
Contact us: http://ecommerce.aheadworks.com/contacts/ 

Copyright © 2015 aheadWorks  http://www.aheadworks.com
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