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Extension page: http://ecommerce.aheadworks.com/magento-extensions/advanced-newsletter.html
The Advanced Newsletter extension enhances the default Magento newsletter functionality with a highly customizable
user interface and targeted sign-up options. Supports mailing lists, Mailchimp and third party SMTP server. If for any
reason Advanced Newsletter has been uninstalled – the native newsletter must still work and contain all the subscribers.

Installation
1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate
If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

2. Log in to the Magento backend

3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.
If Compiler status is Disabled, you can skip to the next step
If Compiler is enabled, disable it.
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IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you use
"Run Compilation Process" function, not just "Enable button"

Installing an extension with the Compilation enabled will result in store downtime.

4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:
via the backend:
Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:
On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

5. Download the extension package from your account and extract the downloaded archive

6. Copy the content of /Step_1/ folder to your store's root directory
If you are using a custom theme,
read the instructions here.
In case you are using a custom theme, it is recommended to copy the design files to your current theme's
folders. In case there are several themes in use at the same store, the design files must be copied to
each of them.
Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
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Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

7. Copy the content of /Step_2/ folder to your store's root directory

8. Flush store cache again; log out from the backend and log in again.

Set Up Subscription Form for OnepageCheckout Page
To display segments on the OnepageCheckout OrderReview page, you should open
the app/design/frontend/<your_package>/<your_theme>/template/checkout/onepage/review/info.phtml file, where
<your_theme> is the name of your current theme and <your_package> is your current package. If you haven't ever
changed your store's theme or package, deafult values.
Find the following string:

<?php echo $this->getChildHtml('agreements') ?>
and insert this code after it:

<?php echo $this->getChildHtml('awancheckout') ?>
If searched string is missing (old Magento CE versions), add the above code as last line of the file.

Cron configuration
The Advanced Newsletter extension uses cron for sending emails and synchronization process. Read the following
instructions on setting cron job for your Magento store: http://www.magentocommerce.com/wiki/1__installation_and_configuration/how_to_setup_a_cron_job
Generally it would be enough to run in SSH console of your server:

crontab -e
And insert the following line:

*/3 * * * *

php /<path-to-your-installation/cron.php

After that exit confirming save request.
Once cronjob is set up and running, the extension will be saving every action in the log, which can be viewed in System>Configuration->aheadWorks Extensions->Info->aheadWorks Extensions logging->View log. If you think that the
extension does not work as expected, it is recommended to check the log first. If it is empty or contains very few records,
it may indicate that your cronjob is not set or set improperly. Normally, every cron launch should add 1 or more entries.
Actual quantity of the entries depends on the number of processed events per given cronjob.

Configuration
Note, after the extension is installed, the native Magento newsletter module will be automatically disabled in
System -> Configuration -> Advanced -> Disable Modules Output.
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Therefore, subscription form will be missing in the frontend until you do the basic configuration for the Advanced
Newsletter. The necessary steps are:
1. Define Subscription Form settings
2. Create at least one Segment
To avoid any possible issues please refrain from enabling native Magento Newsletter as long as Advanced
Newsletter extension is installed and enabled.

General Configuration
General | Form configuration | MailChimp configuration
The extension's general settings are located in System-> Configuration-> aheadWorks Extensions-> Advanced
Newsletter backend page (they can also be accessed via Advanced Newsletter-> Settings).

General tab
Display segments at customer registration form - shows/ hides segments
selector in the Create Account screen.
Address to send test emails - defines the recipient of the test emails
Send subscription success notification* - enables / disables auto-notifications
for subscription
Send unsubscription success notification* - enables / disables autonotifications for unsubscription
*How do I edit notification templates?
Managing activation, first subscription, and unsubscription
templates
The Advanced Newsletter extension uses several notification
templates. By default, they are store
in app\locale\en_US\template\email\.
The following files belong to the Advanced Newsletter extension:
advancednewsletter_subscriber_activation.html
advancednewsletter_subscriber_first_subscription.html
advancednewsletter_subscriber_unsubscription.html
You can edit these files in the way you like. Also, you can use the
following variables to make your emails more personalized:
$subscriber.first_name - display subscriber first name
$subscriber.last_name - display subscriber last name
$subscriber.email - display subscriber email
$subscriber.phone - display subscriber phone
$subscriber.confirm_code - display subscriber confirm code
$subscriber.getSalutationText() - display subscriber salutation
$subscriber.getConfirmationLink() - display confirmation link
(only activation template)
$subscriber.getUnsubscriptionLink() - display unsubscription
link
Example of usage:

{{htmlescape var=$subscriber.getSalutationText()}}

Remove Emails Web copies older than X days - sets the period before the web
copy of an email will be removed.
What does it mean?
Since 2.4.0 version, the Advanced Newsletter extension stores the
web copies of all the emails sent through the extension. In case the
http://confluence.aheadworks.com/display/EUDOC/Advanced+Newsletter
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recipient's mail agent or service strips the html formatting, images,
etc., they have a possibility to view an email in their browser. A special
link can be inserted into the outgoing email

Form configuration tab:
Form display style (available values - In block /
AJAX Layer) - defines how the subscription form is
represented.
What is the difference?
In block style shows the full subscription form on
page

AJAX Layer shows the Subscribe button only,
the form opens in a pop-up after the button is
clicked

Display name - enables / disables Name input field
for guest subscribers.
Display Salutation , Salutation 1 and Salutation 2 these option allow a subscriber to choose the proper
salutation text (E.g., Mr. or Mrs.). The selected
salutation text will be preceding subscriber's name in
outgoing emails.
Display phone - shows / hides Phone input field
What if I switch all the options on?
Here's how the subscription form looks like with
all options enabled:
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Segments Style - sets the segment selector
representation
How does it look like?
There are 4 available segments representation
types:
1. Check boxes

2. Multiselect
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3. Radio buttons

4. "None" - if Segment Style is set to this
option, the segments selector will not be
displayed in the frontend.
The customers will be automatically
subscribed to All segments, Store
Default or Category Default segment

Placing the subscription form to a custom position
By default, the extension's subscription form will replace the native one. It is also possible to insert the form to
any other position via CMS.
To make the subscription button/form (depending on how it has been configured from admin) displayed at any
place of the page, insert the following CMS block:

{{block type="advancednewsletter/subscribe" inserted_manually="1"}}

MailChimp configuration tab:
Enabled - select 'Yes', if you want to use MailChimp
MailChimp auto-sync - if 'Yes' is selected, the
information about all subscriptions/unsubscriptions to
any segment is automatically updated in MailChimp. If
'No' is selected, the 'Advanced Newsletter/MailChimp
synchronization' option is available only
API key - a unique MailChimp API key which you
should enter in this field to be able to synchronize
your data with MailChimp. You can get API key at
your MailChimp account configuration - Account >
API Keys & Info page. If there are no keys, you
should create them
List ID - after you specify the API key and XML-RPC
URL values and save the configuration, the List ID
selector will show all the existent MailChimp lists. You
should select the desired one and save the config
once again.
XML-RPC URL - the url which allows the Advanced
Newsletter extension to connect with MailChimp API.
(Only for Advanced Newlestter versions before
2.5.0)
To get more information about MailChimp, visit their main
page - http://www.mailchimp.com/
Note: At least one group should be created in the list
synchronized with MailChimp
http://confluence.aheadworks.com/display/EUDOC/Advanced+Newsletter
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Please note:
Magento store view = MailChimp list
Advanced Newsletter segment = MailChimp group
Starting from version 2.5.0 Advanced Newsletter
extension works ONLY with API version 3.0

Managing Segments
You can add new and manage the existent Segments in Advanced Newsletter > Segments Management backend
page.
You must create at least one segment to enable your customers to subscribe.
Title - segment name displayed in the list of
segments in the frontend
Segment code - a unique code for each segment.
Note that text for this field is case-sensitive and must
exactly correspond to the MailChimp text
Default store - if Segments style is set to 'None' and
Default Subscription is set to 'Store default' in
the Advanced Newsletter Configuration page, the
customers will be automatically subscribed to the
news of the store you specify in this field
Default category - if Segments style is set to 'None'
and Default Subscription is set to 'Category default' in
the Advanced Newsletter Configuration page, the
customers will be automatically subscribed to the
news of the category you specify in this field
Display in store - the store(s) for the segment to be
displayed in
Display in category - the category(s) for the
segment to be displayed in
Visible at frontend - if segment will be visible at
frontend
Display order - if there are several segments, specify
the order for segment displaying in the list

Note: if any segments style (except None) had been
chosen but no segments had been specified to be
displayed on this category page, Advanced
Newsletter block won't be displayed

Auto-management rules
Using Auto-management rules at Advanced Newsletter > Auto-management rules, you can create rules for automatic
subscribing or unsubscribing customers basing on order events.

Rule Information tab allows you to define the Rule Name
and set Status (Active / Inactive)
http://confluence.aheadworks.com/display/EUDOC/Advanced+Newsletter
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In Conditions tab, you can select the criteria for a customer
to be automatically subscribed to / unsubscribed from a
segment.

Note: multiple SKUs must be separated by comma without
spaces

In Actions tab, you are to define the actual action.
Note: Remove from [segments] and Add to [segments]
options are independent from each other. A given rule can
perform either a single action (subscribe or unsubscribe), or
both kinds of action (subscribe and unsubscribe).

Note: Magento Enterprise only. Administrator with limited scope permissions can't save rules

Adding SMTP servers
The Advanced Newsletter extension allows sending emails through custom SMTP servers.
You add a new and manage the existent SMTP servers through Advanced Newsletter -> SMTP Configuration backend
page. You can add external SMTP servers if you want emails to be send through them.
In the Create (Edit) SMTP screen, you are to define Title
(an internal identified), Server name (or IP), User name /
Password combination and Port
Use TLS or SSL option allows selecting the proper security
protocol (if your server does not have any, just set his option
to "No")

Note, the settings in above screen are typical for Gmail
server

To send emails with *@gmail.com account, you should use "Application-specific passwords"
(https://accounts.google.com/IssuedAuthSubTokens)
Often SMTP-server has a limit for sending, e.g. http://support.google.com/mail/bin/answer.py?
hl=en&answer=22839&topic=1669057&ctx=topic
Note: if SMTP Configuration is not specified, email sending will be processed via standard php mail function. In this case,
please, make sure that the email server has been properly configured
(http://www.php.net/manual/en/mail.configuration.php#ini.sendmail-path) and it is still working.
http://confluence.aheadworks.com/display/EUDOC/Advanced+Newsletter
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Synchronization
Synchronization process in the Advanced Newsletter extension uses cron. Cron is run periodically – it handles 20 items
per cron job execution. To set up the cron job, please read the Cron configuration section below.
Go to the Advanced Newsletter > Synchronization backend page. You can easily import all your newsletter
subscribers, templates, and MailChimp subscribers to Advanced Newsletter. Also you can export Subscribers to
MailChimp from this page.

There are 2 additional sections at the Synchronization page:
MailChimp synchronization
Sync to MailChimp - opens new window with
synchronization options
Magento to MailChimp sync options
When you click the Sync to
MailChimp button, a new window with
additional options is opened. There you
can choose:
Synchronize - (subscribed /
unsubscribed / subscribed &
unsubscribed)
Update user names - (yes / no) If it
is required, you can update existing
user names at MailChimp or not

Sync from MailChimp - opens new window with
synchronization options
MailChimp to Magento sync options
After you click the Sync from
MailChimp button, a new window with
additional options is opened. There you
can choose:
Synchronize - (Update statuses /
Update list) Select whether you
want to update only statuses of
people at your MailChimp
subscribers list or the whole list
with names, segments, and
statuses. If you will choose 'update
list' option, updating will be queued
and run by cron later.

Synchronization with Magento newsletter
Synchronizing with the native Newsletter is a one-time
operation, which allows importing existent templates and
http://confluence.aheadworks.com/display/EUDOC/Advanced+Newsletter
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subscribers
Import templates - imports templates from Magento
newsletter to Advanced Newsletter
Import subscribers - imports subscribers from
Magento newsletter to Advanced Newsletter, assigns
them to "old_newsletter_subscribers" segment

Note: The synchronization is always global. So if you run the Magento Enterprise store, please remember - when the
admin with limited scope permissions runs the synchronization, subscribers of all stores are synchronized

Managing subscriptions
Subscribers Grid
The grid is located in Advanced Newsletter-> Subscribers.
The grid lists all the subscribers, both registered customers and guest subscribers. Through this grid, you can:
subscribe to / unsubscribe from specific segments
delete a subscriber record
export subscribers list to a .csv or .xml file

Manage Customers Grid
The grid is located in Advanced Newsletter-> Manage Customers.
The grid lists all the registered customers, disregarding their Newsletter Subscription status. Through this grid, you can
subscribe to / unsubscribe from specific segments.
Also you can considerably increase filters functionality by installing the Market Segmentation Suite extension.

Do not use mass actions for subscription and unsubscription of customers at Customers _> Manage
customers. They work only for Magento native newsletter only. Use Advanced Newsletter -> Manage
Customers instead of it.

Creating templates
The Advanced Newsletter extension stores its email templates separately from the native Newsletter ones. You can
manage extension's templates and queue them for sending through Advanced Newsletter > Templates backend page.
The basic template options (Name, Subject, Sender, etc)
work the same as the native ones.
The extra parameters are:
Segment Codes - in this selector, you can select the
subscribers segments the email is meant for
MSS Rule (requires Market Segmentation Suite
extension) - allows to apply an MSS filter to the
recipients.
Note, if you apply an MSS rule in the Edit Template
screen, a new subscribers segment will be created
and saved automatically
SMTP account - allows selecting a specific SMTP
server that will be used for the sendount
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For the content of the emails, a number of new variables are added:
You can use 4 macrofields:

Also the following variables are available:

To give customers an opportunity to unsubscribe from
newsletters:

{{var awunsubscribe}}
To give customers an opportunity to unsubscribe from a
specific segment:

subscriber.first_name - display subscriber first
name
subscriber.last_name - display subscriber last
name
subscriber.email - display subscriber email
subscriber.phone - display subscriber phone
subscriber.getSalutationText() - display
subscriber salutation

{{var awunsubscribefromsegment}}
To give customers an opportunity to go directly to the
login page and then manage their subscriptions:

{{var awloginpage}}
To insert the link to the web copy of an email:

{{var external_url}}

Market Segmentation Suite integration
Market Segmentation Suite (MSS) extension in conjunction with
Advanced Newsletter can prove a useful marketing tool by implementing
precise email targeting possibilities.
The Advanced Newsletter Integration allows validate the newsletter
recipients via MSS rule. The rules are applied in Advanced Newsletter > Templates -> Create / Edit Template screen.
Click to see the screenshot

Uninstall
If you just need to temporary disable the extension, you can just do the steps 1-5, without deleting the files of the
extension.
Disable compilation, in case it is enabled.
Login to your FTP, navigate to app/etc/modules/
http://confluence.aheadworks.com/display/EUDOC/Advanced+Newsletter

12/14

04.08.2017

Advanced Newsletter - Documentation - Confluence

Open the file AW_Advancednewsletter.xml and change the following line:
<active>true</active>

to
<active>false</active>

Now your Magento is unaware of the existence of this module.
Enable the native Magento Newsletter via System > Configuration > Advanced > Disable Modules Output tab
Clear the cache under var/cache
Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.
If everything works fine, it is safe to delete the files of the extension.
In case you need to clean the database, backup your database and then run the following queries in MySQL:

DROP
DROP
DROP
DROP
DROP
DROP
DROP
DROP
DROP
DROP
DROP

TABLE
TABLE
TABLE
TABLE
TABLE
TABLE
TABLE
TABLE
TABLE
TABLE
TABLE

IF
IF
IF
IF
IF
IF
IF
IF
IF
IF
IF

EXISTS
EXISTS
EXISTS
EXISTS
EXISTS
EXISTS
EXISTS
EXISTS
EXISTS
EXISTS
EXISTS

'aw_advancednewsletter_automanagement';
'aw_advancednewsletter_cache';
'aw_advancednewsletter_queue';
'aw_advancednewsletter_queue_link';
'aw_advancednewsletter_queue_store_link';
'aw_advancednewsletter_segment';
'aw_advancednewsletter_smtp';
'aw_advancednewsletter_subscriber';
'aw_advancednewsletter_subscriptions';
'aw_advancednewsletter_template';
'aw_advancednewsletter_templates';

delete from core_resource where code ='advancednewsletter_setup';

Note, if you are using the table with prefixes, you must specify them in all table names.
If you are not sure how to do that or expect any troubles with it, please contact your server administrator regarding
the matter.

Note: Making the Advanced Newsletter module disabled in the System > Configuration > Advanced section in the
backend, does NOT disable the extension completely. Native Magento newsletter will work incorrectly then.

Troubleshooting
After the extension installation the store gives an error, or blank page, or suggests to start Magento installation
procedure.
Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear
the store cache and try again.
There is no aheadWorks extensions under my configuration section, or having the extension tab clicked I get a
blank page, or Access Denied error.
Clear the store cache, browser cookies, logout and login again.
I've set up everything correctly, inserted the HTML code but there is nothing on that page.
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Clear the store cache, clear your browser cache and domain cookies and refresh the page.
My configuration changes do not appear on the store.
Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com
License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt
Contact us: http://ecommerce.aheadworks.com/contacts/
Copyright © 2015 aheadWorks http://www.aheadworks.com
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