Powered by Adobe Commerce 2.4.5-p1

magento-2-limit-product-quantity-per-customer.jpg

Limit Product Quantity Per Customer

PRODUCT:
0
TOTAL:

Overview

Back to top

The primary function of the Magento 2 limit product quantity per customer extension is to limit the purchase quantity of any product for any customer or customer group. The secondary function is to encourage customers to buy complementary products along with their original purchase. You can set a maximum limit for any product and display an error message if a customer attempts to exceed the limit or if he does not buy the chosen conditional product(s). You can also set a date range to enforce the restriction for a specific duration.  

Magento 2 limit product quantity per customer extension allows you to prevent your best selling items from going out of stock during peak days or sales offers. By limiting the purchase quantity per customer, you can serve maximum customers. It also helps you increase your average order value by associating other relevant products to complement their purchase.  

 

Key Features

  • Limit order quantity for all or selected products
  • Limit product quantity per customer or customer group
  • Prompt customers to buy complementary products
  • Define a maximum quantity limit
  • Create error messages for maximum quantity & conditional products
  • Specify the restriction date range

 

Limit Order Quantity Of Any Product

The extension allows you to control the order quantity of any product and any number of products. 

 

Limit Order Quantity For Any Customer/Group

Want to apply the restriction to specific customers or customer group(s)? All you have to do is select them when limiting a product. 

 

Choose Relevant Products

If you feel the need for customers to buy additional products with their original one, you can force them to do so. They won’t be able to checkout until they add all the conditional products to the cart. 

 

Define A Maximum Quantity Limit

You can set a limit for a product that you don’t want customers to exceed from.

 

Create Error Messages

You can create error messages that you think will inform customers adequately about the maximum quantity limit for a specific product and/or about the additional products they have to buy. 

 

Specify A Date Range

Select a start and end date you want for the restriction. If no date is specified, no restriction will be enforced. 

 

FAQs:

Is it necessary to force customers to buy additional products?

No, it’s not. If you don’t feel the need, you should not select any product and hence there will be no enforcement. 

Is it necessary to specify a date range?

Yes. It helps you run the restriction for a specific duration. If you want to run it forever, you can set the date many years from the current date. 

Can I limit the product quantity for specific customers?

Yes. You can limit the purchase quantity of any product for any customer or customer group.

Is it compatible with configurable and grouped products?

Yes. The extension is fully compatible with simple, configurable, and grouped products. 

 

How Does The Extension Work?

After installing the extension, go to the extension configurations where you can enable/disable the module and also customize the error messages to be displayed when someone exceeds the quantity limit or does not purchase the additional products you have selected. The message will popup when customers click the “Proceed to Checkout” button. 

To set a quantity limit for a product, go to the product’s edit page where you will see a new section “FME Limit Order Quantity per Customer” added. From here, you can define the duration, apply the restriction on all or specific customers or groups and select the product(s) customers have to buy along with the one they are interested in. 

 

Demo Links

Front End | Back End   

Technical Specifications

Back to top

Seller profile

FMEextensions

Seller contact

E-mail

Current Version

1.0.6

Adobe Commerce platform compatibility

Open Source (CE): 2.4 (current), 2.3 (obsolete)

Commerce on prem (EE): 2.4 (current), 2.3 (obsolete)

Type

Stable Build

Updated

30 September, 2022

Categories

Extensions, Sales, Point of Sale (POS), Rewards & Loyalty

Supported Browsers

Chrome, Firefox, Opera, Safari, Edge, IE

Quality Report

Back to top

Installation & Varnish Tests

Passed

Coding Standard

Passed

Plagiarism Check

Passed

Malware Check

Passed

Marketing Review

Passed

Manual Testing

Passed

All tests were conducted on the latest versions of Adobe Commerce that existed for the compatible release lines at the moment of the extension submission. Latest versions of all other software were used, as applicable.

Release Notes

Back to top

1.0.6:

  • Compatible with Open Source (CE) : 2.3 2.4
  • Compatible with Commerce on prem (EE) : 2.3 2.4
  • Stability: Stable Build
  • Description:

    - Compatible with Magento 2.4.5

1.0.4:

  • Compatible with Open Source (CE) : 2.3 2.4
  • Compatible with Commerce on prem (EE) : 2.3 2.4
  • Stability: Stable Build
  • Description:

    - Compatible with Magento 2.4.0, 2.4.1, 2.4.2, 2.4.3 2.4.4

1.0.3:

  • Compatible with Open Source (CE) : 2.3 2.4
  • Compatible with Commerce on prem (EE) : 2.3 2.4
  • Stability: Stable Build
  • Description:

    - Stable Release.
    - Compatible With Magento 2.4.0, 2.4.1, 2.4.2, 2.4.3.

Support

Back to top

The best place to start if you need help with a specific extension is to contact the developer. All Adobe Commerce developers have both a contact email and a support email listed.

Contact Vendor

Q & A

Back to top

Reviews

Back to top