Age Verification Popup

Age Verification Popup

Compatible With: Community 1.7, 1.8, 1.8.1, 1.9, 1.9.1, 1.9.2, 1.9.3

Tech Specifications

Current Version:
Stable Build
10 March, 2018
Extensions, Content & Customizations, Personalization & Experience Management
Supported Browsers:
Chrome Linux: 42, 43, 44 Windows: 39, 40, 42, 43, 44 Firefox Linux: 40, 41 Windows: 31, 38, 39, 40, 41
License Type:
Open Software License 3.0 (OSL-3.0)


Age Verification Popup provides functionality to verify a website visitor's age before allowing them to enter the website.

Other Extensions by Dotsquares Ltd.


Back to top

Age Verification Popup is a very useful extension to verify a visitor's age if the sold products OR the displayed content is not suitable for children and people under age 18. If a user doesn't verify their age, they will be redirected to any other page link that is suitable to view.

This extension will provide complete control to the admin to manage the content and images on the popup. The admin has full control of which link will be used for redirection if the user fails to verify their age. The admin can select the pages that can be visible without verifying age.

Main Features:

  •     Full control over Age Verification Popup Content through Magento Back-end.
  •     Ability to change content and image of popup.
  •     Ability to select the pages which can be visible without age verification.
  •     Ability to setup the other URL if user doesn’t enter the age.
  •     The admin will have complete authorization to enable/disable this extension.
  •     Compatible with Magento 1.7.x., Magento 1.8.x.,1.9.x

Extension Functionality:

  •     100% Open source.
  •     Don't affect Magento core files.
  •     Improve Sites usability and performance.
  •     Developed using Magento programming guidelines.

Release Notes

Back to top


  • Compatible with CE: 1.7 1.8 1.8.1 1.9 1.9.1 1.9.2 1.9.3
  • Stability: Stable Build
  • Description:

    Compatible with CE: 1.9 1.9.1 1.9.2 1.9.3 Stability: Stable Build Description: Compatible with 1.5 and above


Back to top
The best place to start if you need help with a specific extension is to contact the developer. All Magento developers have both a contact email and a support email listed.

Q & A

Back to top


Back to top